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Introduction

This document explains the installation of the POOSL IDE. This is a plug-in for Eclipse that relies on
the Xtext framework (http://www.eclipse.org/Xtext/) and the POOSL simulator (Rotalumis) of
Eindhoven University of Technology (http://www.es.ele.tue.nl/poosl).

Further information about the use of the POOSL IDE can be accessed through the built-in help.



1 Installation

1.1 Minimal system requirements
The POOSL IDE requires one of the following operating systems:

e Windows 7, 32 bit or 64 bit (Windows XP is not supported)
e Ubuntu 12.04, 32 bit or 64 bit
e Mac OS X 10.10 (Yosemite)

In addition it requires the following installed software:

 Java Runtime Environment (JRE) 1.7.0_55 or newer'  (Java 1.8 is supported)
e Eclipse Luna SR1 (version 4.4.1) for “Java Developers” or for “Java and DSL Developers”

For the JRE and Eclipse, make sure that both are 32-bit versions, or both are 64-bit versions.

1.2 Installing Eclipse
If a correct version of Eclipse is already installed, skip this section. Otherwise, follow these steps to
install Eclipse:

1. Download and Install Java Runtime Environment (JRE), see
http://www.oracle.com/technetwork/java/javase/downloads

2. Download the Eclipse IDE for Java Developers (Eclipse Luna version 4.4.1).
http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunasrl

3. Unzip the Eclipse file at a location where you have permission to write files and directories.
Locate the “Eclipse.exe” file in directory “Eclipse”. Create a shortcut on the desktop or task
bar (In Windows, right click on the file -> Send to -> Desktop). When multiple JREs are
installed on your machine, specify the JRE to be used as follows: right-click on Eclipse
shortcut, select Properties, tab Shortcut; edit the “Target” field to specify the location of the
Java Virtual Machine. For instance:

C:\Eclipse\Luna\Eclipse.exe -vm "C:\Program Files\Java\jre8\bin\javaw.exe"
Note the use of “javaw” to avoid opening a additional window.

When opening Eclipse select a location for the workspace and click OK.

! To determine which version of Java is installed, type the following at the command prompt: java -version
4



1.3 Installing the POOSL IDE plug- in
To install the POOSL IDE plug-in in Eclipse follow these steps:

1. In Eclipse go to Help -> Install new software

In “Work with: “, click the Add... button. The Add Repository dialog box appears:
Copy one of the following links to the location box:

* http://poosl.esi.nl/downloads/ide/updates/release/ for the release version

e http://poosl.esi.nl/downloads/ide/updates/latest/ for the latest version

4. Enter a name for the repository and click OK.

r = .
= Add Repository &J

Mame: POO5L IDE Relea 5es.| Local... |
Locatiom:  http://pooslesinl/downloads/ide/updates/release/

won

@' L Ok I [ Cancel l

g
5. Select the POOSL IDE plug-in from the update site and check the “Contact all update sites
during installation to find required software” checkbox.
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6. Click “Next” twice and accept the license agreement, click “Finish” to start the installation.
Because the software is not signed by Eclipse it will give a security warning. Click OK on the
security warning to continue installation.
¢ Installing the POOSL IDE plugin will automatically install the simulator (Rotalumis).

7. When asked, restart Eclipse.

If an error is reported during installation, please consult section 4.3 and section 4.4.

1.4 Updating the POOSL IDE
To update the POOSL IDE follow these steps:

1. In Eclipse select Help -> Check for Updates. If a newer version of the POOSL IDE or the
simulator (Rotalumis) are available, they will appear in the list of software to update.
2. Click Next to install the new updates.

1.5 Installation problems
In case errors occur after installing the POOSL IDE when opening files or running or debugging
models, make sure that the correct versions of the following software are installed:

¢ Java Runtime Environment (JRE) 1.7.0_55 or newer (see section 1.1)
e Eclipse Luna SR1 (4.4.1) or newer (see section 1.1)
0 Check at Help -> About Eclipse
e Xtext 2.6.x or newer
0 Check at Help -> About Eclipse -> Installation Details -> Installed Software

Xtext should have been installed automatically during the installation of the POOSL IDE. If it is missing
or an old version is present, it can be installed or updated using the Xtext update site:
http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/ .




2 Testyour installation using the examples

This section describes a procedure to check whether the installation was successful, and whether the
POOSL IDE has enough permissions on your computer. To use the POOSL IDE to its full potential, it
needs enough permissions to write files and to create socket connections on your machine.

2.1 Download the example POOSL project

The example POOSL project can be downloaded from
http://poosl.esi.nl/downloads/examples/examples.zip. Save the file in a temporary location; do not
unzip the files or extract files from the zip file.

2.2 Import the example POOSL project
To create a POOSL project with the examples, follow these steps:
1. Click on File -> Import... -> General -> Existing Projects into Workspace.
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2. Click on Select archive file, and press Browse... to open the examples.zip file.
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3. Click Finish to import the project.

2.3 Testyour installation using an example
1. Click on Window -> Open Perspective -> Other... -> POOSL Edit, which changes the screen
layout in order to support the editing POOSL models.
2. Double-click on the file producer_consumer.poosl. Check that the contents of the file is
shown in a syntax-highlighted way.
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3. Right-click on the file producer_consumer.poosl and select Debug as -> POOSL simulation.
The screen layout is changed in order to support the debugging of POOSL models.
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4. If no element is selected in the Debug view (top-left corner), then select any element.
5. Inthe top-left corner, click on the green Resume button (indicated by the green arrow in the
picture below). Check that the Sequence Diagram in the bottom-right corner fills up with

messages.
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6. Inthe top-left corner, click on the red Terminate button (indicated by the red arrow in the
picture above).
7. Inthe top-right corner, click on POOSL Edit to change back to the screen layout for editing.
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3 User manual

The user manual for the POOSL IDE can be found inside the Eclipse environment. It can be opened in
several ways:

1. Click on the Help menu, and select “Help Contents”.

This will open the Eclipse built-in help in a separate window. The POOSL documentation is
located under Contents in the Poosl booklet.

= [51-]] Poosl
4 Editing
B8 Running and debugging
L] Irnporting and exporting
Bl Preferences

E FAQ

The recommended starting point for new users is Editing -> Create Projects and Models.

Click on the Help menu, and select “Dynamic help” (Or use keyboard shortcut <F1>).

This will open a window inside Eclipse. It shows brief information about the selected view, in
combination with references to the help Contents.

D Help 52 e

Contents

]
T; Search =3 Related Topi:s [Iu Bockmarks & Index

About Poosl Editor

The POOSL editor provides you with POOSL specific text editing support.

This includes syntax highlighting, hovers, navigation, validation and
content assist (<CTREL>+<5PACE=).

See alsos

2] Creating models
& Editing models
Meore results:

2 Search for About Poosl Editor

To switch between the main documentation (“Contents”) and the dynamic help (“Related
Topics”), use the tabs on top of the help page.

10



4 FAQ

4.1 <CTRL>-<SPACE> does not work.

This is a general Eclipse problem. Some suggestions for solutions can be found online, such as:

1. Create a new workspace, and import your existing projects. Remember to check “Copy projects
into workspace” to copy all your existing work to new workspace.

2. Make sure that the <CTRL>+<SPACE> combination is not hijacked by any other application (such as
text input features).

3. Make sure “regional and language options” is in English language. For example, Windows, Control
panel —> Region and language options. Then

¢ Administrative (tab) —> Language for non-Unicode program. Make sure English (United
States) is selected, others may not work.

¢ Keyboards and Languages (tab) —> Change Keyboards. You'll see a list of languages
installed; remove any that you don’t want (click the language and then click the Remove
button) until you only have the ones you want left.

4. Change the key combination in Eclipse, via Window -> Preferences -> General -> Keys. The default
binding for command “Content Assist” is “Ctrl + Space”, but this can be changed into something else.

4.2 Internal null pointer exception when trying to run/debug a model.
The following error may occur when you try to run or debug a model:

An internal error occurred during: "Launching ...poosl". java.lang.NullPointerException

It usually indicates that your version of the Java Runtime Environment (JRE) is too old. Please check
the minimal system requirements in section 1.1.

4.3 Cannot complete the install because of a conflicting dependency.
The following error may occur during the installation of the POOSL IDE:

Cannot complete the install because of a conflicting dependency

If the remaining message refers to different version of the Eclipse Workbench, then it usually
indicates that your version of Eclipse is too old. Please check the minimal system requirements in
section 1.1.

4.4 An error occurred while collecting items to be installed
The following error may occur during the installation of the POOSL IDE:

An error occurred while collecting items to be installed

session context was:(profile=epp.package.java,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Followed by the repositories it cannot find:
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No repository found containing: osgi.bundle,nl.esi.poosl.generatedxmiclasses,3.2.0.201501141011
No repository found containing: ... ... ...
This is a known problem in Eclipse and it can be solved by reloading the software site.

1. Go to Help-> Install New Software, then select “"Available Software Sites”.
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2. Select the POOSL IDE site, and click “edit”. Change the location by removing or adding the trailing “/",
and click "OK".

3. Select the POOSL IDE site, and click "Reload”. Reloading may take a minute.

4. Once the software site has been reloaded, click "OK" to go back to the “Install New Software” screen.
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5.

The problem should now be resolved. Select the POOSL IDE site from the dropdown box to continue the
installation at point 5 of the manual (section 1.3).
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4.5 LSomething doesn’t (seem to) work.

First of all, check whether your system meets the minimal installation requirements (see section 1.1),
and the other FAQ. Depending on the problem, the following information may support experts in
solving the problem that you experience:

Version of the Java Runtime Environment

0 Atthe command prompt, type: java -version
Version of Eclipse

0 Help -> About Eclipse
Version of Xtext

0 Help -> About Eclipse -> Installation Details -> Installed Software
Version of Rotalumis

0 Help -> About Eclipse -> Installation Details -> Installed Software
Eclipse log

0 Help -> About Eclipse -> Configuration -> View Error Log
Log of the communication between Eclipse and the simulator

0 Set the logging level in the preferences

0 The Logging.html file can be found in the root of the Eclipse installation
Console output and/or Eclipse screenshot
The .poosl files causing the problem
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